DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2009-04-18 14:23:47

octocom
New member
Registered: 2009-04-18
Posts: 4

Acer Aspire EasyStore Fun_plug, almost the same firmware as DNS-343?

Hi all

I understand that this fourm is not for acer Aspire but I cant find any good fourm.  I hope you can help as its almost the same firmware source.

I have got working Fun_plug working by rename the script to ES_plug and modfiying the script to install at FFP_PATH=/mnt/HD_a4/ffp . if I dont modify the the script to the new location it will not save any settings on reboot.

most of  Fonz fun_plug 0.5 works no problem at all, but I would like to install twonky and this is where I am stuck.

I have downloaded twonky version twonkymedia-armel-glibc-2.2.5-4.4.11-20090108 and also twonkymedia-dns323-20081002.

I have then used the twonky armel glibc to overwrite files in the twonky323 and then modifed install script for anything with  /mnt/HD_a2 to  /mnt/HD_a4

I have then run program nassetup

after installion there is an error which Im not sure how to fix

grep /mnt/HD_a4/fun_plug: no such file or directory

Offline

 

#2 2009-04-18 21:09:45

fonz
Member / Developer
From: Berlin
Registered: 2007-02-06
Posts: 1716
Website

Re: Acer Aspire EasyStore Fun_plug, almost the same firmware as DNS-343?

Thanks for reporting. I've added the Acer Aspire EasyStore to the list of devices at http://dns323.kood.org/howto:ffp#installation

Regarding twonky, you need a binary that matches the firmware libraries. If the Acer firmware is similar to the 343 firmware, then it is glibc-based (so the dns-323 binary will not work, as it's uclibc-based) and you need to find a compatible twonky binary. You find out the glibc version like this:

Code:

# /lib/libc.so.6 
GNU C Library stable release version 2.3.6, by Roland McGrath et al.
...
Compiled by GNU CC version 3.4.4 (release) (CodeSourcery ARM 2005q3-2).
Compiled on a Linux 2.6.12-rc3 system on 2006-02-12.
...

Also, the DNS-343 uses ARM-EABI:

Code:

# readelf -h /lib/libc.so.6 
ELF Header:
...
  Flags:                             0x4000002, has entry point, Version4 EABI

So, twonkymedia-armel-glibc-2.2.5-4.4.11-20090108 looks like a good choice.

Offline

 

#3 2009-04-19 23:29:16

phoenixnx
New member
Registered: 2009-04-19
Posts: 1

Re: Acer Aspire EasyStore Fun_plug, almost the same firmware as DNS-343?

Gidday octocom

I found your post this morning and hope you can help me out.

I am a noob to linux and recently purchased a Acer Aspire Easystore.  I have hopes to load it with a bittorrent program and have tried the fun-plug.  It worked, but same problem as you descriped.

Reading your post, you modified the install script to 'FFP_PATH=/mnt/HD_a4/ffp'.  Would this be because you have a single drive, mounted in the top bay?

I have a single drive mounted in top bay, and came across the same problem, with a reboot, I lost SSH and Telnet.

I have attempted mldonkey torrent program, but ran into lost passwords also.  figured mldonkey would be good as it has a web interface.

But I am interested in Twonky for DLNA as well, though the NAS's upnp server is acceptable for most things, but have received error messages on my ps3's.

Any help would be greatly appreciated.

Rob

Offline

 

#4 2009-04-20 21:16:55

octocom
New member
Registered: 2009-04-18
Posts: 4

Re: Acer Aspire EasyStore Fun_plug, almost the same firmware as DNS-343?

Hi Phoenixnx

The reason for the change is todo with the data partion "I think" because There is an NTFS with write access for data but all settings are store on the linux Partion Ext3.

So what I have done is installed ffp on HD_4 along with  other program settings  and also the program scripts "sh"  but with them being modfied to point back to to HD_a2 for most of the large programs.

I still cant get twonky to work,  but I can now get it to start and see port 9000 but its at status is wait?

So im working on getting java for armel to work so I can use MYiHome

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB