DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2008-09-06 03:38:08

rcblackwell
Member
From: Pickering, ON
Registered: 2008-05-19
Posts: 204
Website

Enabling SWAT

I'm a Linux newbie whose seeking a little help on configuring fun_plug to run SWAT.

The Samba package from fonz's site has been installed. It's running fine, sharing files to the PC's on my network. Tonight I thought I'd attempt configuration of fun_plug so I could use SWAT to edit the samba config file. Following instruction found within the package I added two files to /ffp/etc. The two files are services and inetd.conf. The services file contains the following line;

swat 901/tcp

the inetd.conf file contains the following line;

swat stream tcp nowait.400 root /ffp/sbin/swat swat

Once these two files were added the inetd service was started using the inetd.sh. Performing ps indicates inetd is running however when I attempt to launch SWAT (http://162.168.1.50:901/) from Firefox I get a "Failed to Connect" error.

Unfortunately searching the forum provided little in the way of resolution thus I'm posting in hope someone here can help. What have I missed?


Bob Blackwell
Pickering, ON

Offline

 

#2 2008-09-06 12:50:46

fonz
Member / Developer
From: Berlin
Registered: 2007-02-06
Posts: 1716
Website

Re: Enabling SWAT

Almost. You need to add 'swat 901/tcp' to /etc/services (not /ffp/etc/services).

Code:

echo 'swat 901/tcp' >>/etc/services
cat /ffp/etc/examples/inetd.conf-swat >>/ffp/etc/inetd.conf
sh /ffp/start/inetd.sh restart

/etc/services will be reset on reboot, so you need to repeat the first command on every reboot. If you're running a recent release of 0.5, you can add the echo command to /ffp/etc/fun_plug.local.

Offline

 

#3 2008-09-07 00:56:50

rcblackwell
Member
From: Pickering, ON
Registered: 2008-05-19
Posts: 204
Website

Re: Enabling SWAT

fonz wrote:

Almost. You need to add 'swat 901/tcp' to /etc/services (not /ffp/etc/services).

Code:

echo 'swat 901/tcp' >>/etc/services
cat /ffp/etc/examples/inetd.conf-swat >>/ffp/etc/inetd.conf
sh /ffp/start/inetd.sh restart

Worked like a charm.

Thank you very much fonz

Last edited by rcblackwell (2008-09-07 02:39:09)


Bob Blackwell
Pickering, ON

Offline

 

#4 2008-09-07 02:49:20

rcblackwell
Member
From: Pickering, ON
Registered: 2008-05-19
Posts: 204
Website

Re: Enabling SWAT

fonz wrote:

/etc/services will be reset on reboot, so you need to repeat the first command on every reboot. If you're running a recent release of 0.5, you can add the echo command to /ffp/etc/fun_plug.local.

A file named /ffp/etc/fun_plug.init exists however there's no /ffp/etc/fun_plug.local. With this finding I must assume I'm running an earlier version of ffp 0.5? what would be the best way to upgrade to the latest version? I've made changes to a few scripts since original installation of ffp which I think was done in April. Should I save elsewhere the script changes I made then copy them back to the appropriate directories after performing an update? What harm if any could be caused by upgrading?


Bob Blackwell
Pickering, ON

Offline

 

#5 2008-09-07 11:37:05

fonz
Member / Developer
From: Berlin
Registered: 2007-02-06
Posts: 1716
Website

Re: Enabling SWAT

rcblackwell wrote:

A file named /ffp/etc/fun_plug.init exists however there's no /ffp/etc/fun_plug.local.

fun_plug.local is never installed (and will never be overwritten by package upgrades). You need to create it yourself. There should be an example in /ffp/etc/examples.

Offline

 

#6 2008-11-17 01:28:56

BigNoob
Member
Registered: 2008-11-17
Posts: 7

Re: Enabling SWAT

I'm a very big newbie and I'm interresting by enable Swat.
But I'm not sure to understand this topic! I would to know step by step how to proceed.
If you can help me please! smile

tell me what I have wrong or forget because I do that

1. edit /etc/services and add swat 901/tcp in file
2. edit inetd.conf and add swat stream tcp nowait.400 root /ffp/sbin/swat swat in file

I take inetd.cond from exemple and past on /ffp/etc
I'm not sure that correct

After how to run the service? I must lanch inetd.sh? (if yes how to? I must go in /mnt/HD_a2/ffp/start/ and after?)

3. past fun_plug.local and edit to add:

echo 'swat 901/tcp' >>/etc/services
cat /ffp/etc/examples/inetd.conf-swat >>/ffp/etc/inetd.conf
sh /ffp/start/inetd.sh restart

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB