DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#251 2010-04-12 21:05:46

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

It's very difficult with regular expression to exclude a specific number range. I currently can't think of a way to do it, but I'll keep you updated if I'm able to figure it out.

Last edited by KyleK (2010-05-16 19:45:32)

Offline

 

#252 2010-04-12 21:27:48

nyunyu
Member
Registered: 2009-05-03
Posts: 44
Website

Re: [REL] Automatic for funplug-0.5

[Doki] Chu-Bra!! - 01 (848x480 XviD MP3) [D5296211].avi

Above is the is the file name. Thanks.


DNS323 + 2x1TB WD GREEN + Fun Plug 0.5 (Fonz) + Transmission 1.92 + Automatic 0.6 = GREAT!
Looking for Auto Direct Download script if possible smile

Offline

 

#253 2010-04-12 21:30:17

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Yeah, I know. But there's no way to exclude "01" and "02" from the match but include everything else. (It's even worse here because there are numbers all over the place).

I'd say just leave that part out, and when Automatic adds these torrents to Transmission, remove them manually. Automatic will remember that it has downloaded them before, and won't add them again.

Offline

 

#254 2010-04-12 22:05:18

nyunyu
Member
Registered: 2009-05-03
Posts: 44
Website

Re: [REL] Automatic for funplug-0.5

I see, then I will need to monitor the downloads then.
Thanks for the help man, appreciated it a lot.


DNS323 + 2x1TB WD GREEN + Fun Plug 0.5 (Fonz) + Transmission 1.92 + Automatic 0.6 = GREAT!
Looking for Auto Direct Download script if possible smile

Offline

 

#255 2010-04-17 23:07:10

r2d290
Member
Registered: 2010-04-07
Posts: 25

Re: [REL] Automatic for funplug-0.5

Hi there. I got Autamtic work with the public-rss in version 0.6, but got some problems when I wanted to edit the config-file to get RSS working on my private tracker. the tracker-site is replaced with "#". I guess the problem is the feed? It complains about mismatch for the opening and ending tag. I know that "Ubuntu" is in the list of the newest torrent (and a part of the RSS-list), and I know that the link+cookie is working with RSS using uTorrent. Any support?

root@nsa220plus:~# automatic -f
../src/automatic.c, 530: 1 feed URLs
../src/automatic.c, 531: Read 1 filters from config file
../src/state.c, 100: [load_state] Error: Unable to open statefile '/root/.config/automatic.state' for reading: No such file or directory
Entity: line 5: parser error : Opening and ending tag mismatch: link line 3 and head
</head>
       ^
Entity: line 12: parser error : Opening and ending tag mismatch: img line 12 and td
<img src="/pic/######.gif" align="left" cellpadding="0" ></td>
                                                               ^
Entity: line 24: parser error : Opening and ending tag mismatch: td line 11 and tr
</td></tr></table></td></tr>
          ^
Entity: line 24: parser error : Opening and ending tag mismatch: tr line 11 and table
</td></tr></table></td></tr>
                  ^
Entity: line 24: parser error : Opening and ending tag mismatch: table line 11 and td
</td></tr></table></td></tr>
                       ^
Entity: line 24: parser error : Opening and ending tag mismatch: td line 11 and tr
</td></tr></table></td></tr>
                            ^
Entity: line 31: parser error : Input is not proper UTF-8, indicate encoding !
Bytes: 0xF8 0x76 0x65 0x72
<p><b>Error-message</b> The page yau are trying to access, is not accessable before you log in.</p>
                                  ^
Entity: line 34: parser error : AttValue: " or ' expected
<p>You got <b><font color=green>6</font></b> attempts left.</p>
                               ^
Entity: line 34: parser error : attributes construct error
<p>You got <b><font color=green>6</font></b> attempts left.</p>
                               ^
Entity: line 34: parser error : Couldn't find end of Start Tag font line 34
<p>You got <b><font color=green>6</font></b> attempts left.</p>
                               ^
Entity: line 34: parser error : Opening and ending tag mismatch: b line 34 and font
<p>You got <b><font color=green>6</font></b> attempts left.</p>
                                             ^
Entity: line 34: parser error : Opening and ending tag mismatch: p line 34 and b
<p>You got <b><font color=green>6</font></b> attempts left.</p>
                                                 ^
Entity: line 34: parser error : Opening and ending tag mismatch: form line 32 and p
<p>You got <b><font color=green>6</font></b> attempts left.</p>
                                                                       ^
Entity: line 36: parser error : AttValue: " or ' expected
<table border="0" cellpadding=5>
                              ^
Entity: line 36: parser error : attributes construct error
<table border="0" cellpadding=5>
                              ^
Entity: line 36: parser error : Couldn't find end of Start Tag table line 36
<table border="0" cellpadding=5>
                              ^
Entity: line 37: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
              ^
Entity: line 37: parser error : attributes construct error
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
              ^
Entity: line 37: parser error : Couldn't find end of Start Tag td line 37
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
              ^
Entity: line 37: parser error : Opening and ending tag mismatch: tr line 37 and td
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                      ^
Entity: line 37: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                                ^
Entity: line 37: parser error : attributes construct error
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                                ^
Entity: line 37: parser error : Couldn't find end of Start Tag td line 37
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                                ^
Entity: line 37: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                                                             ^
Entity: line 37: parser error : attributes construct error
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                                                             ^
Entity: line 37: parser error : Couldn't find end of Start Tag input line 37
<tr><td class=rowhead>Username:</td><td align=left><input type="text" size=40
                                                                             ^
Entity: line 38: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
              ^
Entity: line 38: parser error : attributes construct error
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
              ^
Entity: line 38: parser error : Couldn't find end of Start Tag td line 38
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
              ^
Entity: line 38: parser error : Opening and ending tag mismatch: tr line 38 and td
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                   ^
Entity: line 38: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                             ^
Entity: line 38: parser error : attributes construct error
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                             ^
Entity: line 38: parser error : Couldn't find end of Start Tag td line 38
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                             ^
Entity: line 38: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                                                              ^
Entity: line 38: parser error : attributes construct error
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                                                              ^
Entity: line 38: parser error : Couldn't find end of Start Tag input line 38
<tr><td class=rowhead>Password:</td><td align=left><input type="password" size=40
                                                                              ^
Entity: line 38: parser error : Opening and ending tag mismatch: table line 27 and td
ssord:</td><td align=left><input type="password" size=40 name="password" /></td>
                                                                               ^
Entity: line 38: parser error : Opening and ending tag mismatch: td line 26 and tr
d:</td><td align=left><input type="password" size=40 name="password" /></td></tr
                                                                               ^
Entity: line 39: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
              ^
Entity: line 39: parser error : attributes construct error
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
              ^
Entity: line 39: parser error : Couldn't find end of Start Tag td line 39
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
              ^
Entity: line 39: parser error : Opening and ending tag mismatch: tr line 39 and td
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                 ^
Entity: line 39: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                           ^
Entity: line 39: parser error : attributes construct error
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                           ^
Entity: line 39: parser error : Couldn't find end of Start Tag td line 39
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                           ^
Entity: line 39: parser error : AttValue: " or ' expected
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                                            ^
Entity: line 39: parser error : attributes construct error
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                                            ^
Entity: line 39: parser error : Couldn't find end of Start Tag input line 39
<tr><td class=rowhead>Automatic log-in</td><td align=left><input type=chec
                                                                            ^
Entity: line 39: parser error : Opening and ending tag mismatch: tr line 26 and td
checkbox name="logout" value="no">Remember the username and password on this computer</td>
                                                                               ^
Entity: line 40: parser error : AttValue: " or ' expected
<tr><td colspan="2" align="center"><input type="submit" value="Log in!" class=
                                                                               ^
Entity: line 40: parser error : attributes construct error
<tr><td colspan="2" align="center"><input type="submit" value="Log in!" class=
                                                                               ^
Entity: line 40: parser error : Couldn't find end of Start Tag input line 40
<tr><td colspan="2" align="center"><input type="submit" value="Log in!" class=
                                                                               ^
Entity: line 43: parser error : Opening and ending tag mismatch: br line 7 and form
</form>
       ^
Entity: line 44: parser error : Opening and ending tag mismatch: body line 6 and td
</td></tr></table></td></tr></table>
     ^
Entity: line 44: parser error : Opening and ending tag mismatch: head line 1 and tr
</td></tr></table></td></tr></table>
          ^
Entity: line 44: parser error : Opening and ending tag mismatch: html line 1 and table
</td></tr></table></td></tr></table>
                  ^
Entity: line 44: parser error : Extra content at the end of the document
</td></tr></table></td></tr></table>
                  ^
../src/xml_parser.c, 170: Error: Unable to parse input data!

Here is a cut of the config-file:

##############################
## Version-specific options ##
##############################

# For Transmission 1.3x and newer only: If you configured Transmission/Clutch to use password authentication, Automatic needs that information as well
rpc-auth = "r2d290:aPassword"

#####################
## General options ##
#####################


# list of feed URLs. You can specify one or more feeds, in case of the latter use curly brackets (see the "patterns" option for an example)
# url = "http://rss.thepiratebay.org/205"

feed = { url => "http://www.#####.###/rss.php?feed=dl&cat[]=14&cat[]=20&cat[]=26&cat[]=24&cat[]=25&cat[]=10&cat[]=6&cat[]=8&cat[]=22&cat[]=4&cat[]=27&cat[]=1:COOKIE:uid=11111;pass=0b1b1a1111a11a1aa1a11aaaa1111111" }

# interval in minutes between checks for new downloads
interval = 1

# Automatically add downloaded torrents to Transmission (requires
# transmission-daemon and transmission-remote to be installed or use
# of "external" option)
# If this is not set, all Automatic will do is save the .torrent file.
use-transmission = yes

# Instruct Transmission to immediately start downloading torrents after being added
# If set to 'no' torrents will be added in a paused state
start-torrents = yes

# path where Automatic will store downloaded torrents
torrent-folder = "/tmp"

# path to the file which stores information about already downloaded torrents (so they don't get readded to Transmission)
statefile = "~/.config/automatic.state"

# Prowl API key. You can use this to send push notifications to an iPhone. See http://prowl.weks.net for more information
#prowl-apikey = ""

# patterns contains a number of regular expressions which are matched against the RSS feed entries
# please don't use curly brackets within a regular expression, it'll horribly break the configuration parser smile
# letter-casing does not matter

# patterns =  {
#           "Ubuntu"
#           "Something.else.to.download.*720p"
#               "(?!.*720p)Some.Video.But.Not.The.HD.Version"
#             }


filter = { pattern => "Ubuntu"
           folder => "/mnt/HD_a2/Downloads/Ubuntu"
         }

Last edited by r2d290 (2010-04-18 00:59:26)

Offline

 

#256 2010-04-18 18:21:51

nyunyu
Member
Registered: 2009-05-03
Posts: 44
Website

Re: [REL] Automatic for funplug-0.5

KyleK, sorry to bother you yet again. Is this correct patterns?

"The.Vampire.Diaries.S0[1-9]E.*XviD"
Original: The.Vampire.Diaries.S01E01.Pilot.HDTV.XviD-FQM.avi

Also, I asked you about this patterns before and you confirmed it was correct, I just wonder if it is indeed correct as my Transmission did not download any new series.

"Chuck.*S0[3-9]E.*xvid" --> how automatic knows the episode number? Is this correct pattern?

below are what I have in my automatic.conf.

Code:

filter = { pattern => "Chuck.*S0[3-9]E.*xvid"
           folder => "/mnt/HD_a2/media/tv series"
         }

filter = { pattern => "The.Vampire.Diaries.S0[1-9]E.*XviD"
           folder => "/mnt/HD_a2/media/tv series"
         }

DNS323 + 2x1TB WD GREEN + Fun Plug 0.5 (Fonz) + Transmission 1.92 + Automatic 0.6 = GREAT!
Looking for Auto Direct Download script if possible smile

Offline

 

#257 2010-04-18 19:14:27

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

@rd2d90 Apparently your feed URL isn't correct, as the server does not send an XML-formatted file back, but a HTML file instead. That is why there are so many parser errors. You should check the feed URL. (i.e. Open it with a normal browser, or "download" it with wget or curl and check the resulting file).

@nyunyu
You can test your regular expressions here: http://www.regular-expressions.info/jav … ample.html

Last edited by KyleK (2010-05-16 19:45:56)

Offline

 

#258 2010-04-18 19:22:33

nyunyu
Member
Registered: 2009-05-03
Posts: 44
Website

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

@rd2d90 Apparently your feed URL isn't correct, as the server does not send an XML-formatted file back, but a HTML file instead. That is why there are so many parser errors. You should check the feed URL. (i.e. Open it with a normal browser, or "download" it with wget or curl and check the resulting file).

@nyunyu
The Vampire Diaries pattern is correct, it would match the example you gave.
The Chuck pattern is essentially the same, so I don't know why it didn't work for you. You have to check your feed and see what the Chuck filename looks like.

You can test your regular expressions here: http://www.regular-expressions.info/jav … ample.html

Ok, meaning there must be something wrong with my automatic. Maybe it is not running. May I know how to check if the script is running?
The site you gave seems useful, although I need to find a manual how to use it. lol
Thanks.


DNS323 + 2x1TB WD GREEN + Fun Plug 0.5 (Fonz) + Transmission 1.92 + Automatic 0.6 = GREAT!
Looking for Auto Direct Download script if possible smile

Offline

 

#259 2010-04-18 19:26:01

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Code:

$ /ffp/start/automatic.sh status

This will tell you if Automatic is running.

You can also enable logging by editing the above script with an editor (instructions on how to enable logging are right inside the script itself).

Offline

 

#260 2010-04-18 19:57:55

r2d290
Member
Registered: 2010-04-07
Posts: 25

Re: [REL] Automatic for funplug-0.5

@KyleK: Opening the feed with a web-browser results to a web-site with the last 13 torrents.
And, using the feed in uTorrent gives me the same 13 torrents, and I can make a filter and automaticly download torrents.

The torrent-tracker has categorized many diferent kind of feeds, ex. &cat[]=20 is programs, and &cat[]=14 is movies. Is it posible that it is the brackets "[" and "]" that makes the program to fail?

(btw: see PM)

Offline

 

#261 2010-04-22 20:10:45

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

r2d290 wrote:

@KyleK: Opening the feed with a web-browser results to a web-site with the last 13 torrents.
And, using the feed in uTorrent gives me the same 13 torrents, and I can make a filter and automaticly download torrents.

The torrent-tracker has categorized many diferent kind of feeds, ex. &cat[]=20 is programs, and &cat[]=14 is movies. Is it posible that it is the brackets "[" and "]" that makes the program to fail?

(btw: see PM)

Were you able to resolve this issue?

Offline

 

#262 2010-04-22 20:53:41

r2d290
Member
Registered: 2010-04-07
Posts: 25

Re: [REL] Automatic for funplug-0.5

Nope sad

edit:
Actually, I got more problems now... user root, pw: root. I can't remember that I have ever changed this password (unless we did it while you helped me through icr). Any Idea would be apreaciated smile


login as: root
root@192.168.1.72's password:
Access denied
root@192.168.1.72's password:

Last edited by r2d290 (2010-04-22 20:55:45)

Offline

 

#263 2010-04-23 13:49:06

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

If you've logged yourself out of SSH, then connect via Telnet and reset the password.
If Telnet isn't running anymore, then you'll have to modify fun_plug so that it starts upon reboot of the device.

This problem has occured before and there are posts around here that explain the steps.

Did you read my PM regarding your RSS issue?

Offline

 

#264 2010-04-24 13:06:13

r2d290
Member
Registered: 2010-04-07
Posts: 25

Re: [REL] Automatic for funplug-0.5

Sorry, I did not notice that I got any PM (I'm used to get a big pop-up when I get messages) smile

The telnet-tips worked perfectly. I used the guide at http://dns323.kood.org/howto:ffp#the_root_user and now I am (again) able to connect through SSH.

Is this URL generated directly by the tracker website, or did you attach the ":COOKIE:uid=xxx" part to the end of it?

I had to add the COOKIE-part to the end of it. The generator gave me this:

http://www.#####.###/rss.php?feed=dl&cat[]=14&cat[]=20&cat[]=26&cat[]=24&cat[]=25&cat[]=10&cat[]=6&cat[]=8&cat[]=22&cat[]=4&cat[]=27&cat[]=1

But it worked when I splitted it up like this:

Code:

feed = { url => "http://www.#####.###/rss.php?feed=dl&cat[]=14&cat[]=20&cat[]=26&cat[]=24&cat[]=25&cat[]=10&cat[]=6&cat[]=8&cat[]=22&cat[]=4&cat[]=27&cat[]=1"
      cookies => "uid=*****;pass=*************************"
}

Thank you (again) verry much. You have defeated all my problems now big_smile

Offline

 

#265 2010-04-30 02:24:05

Darkman
Member
From: Sonoran Desert
Registered: 2010-04-23
Posts: 30

Re: [REL] Automatic for funplug-0.5

I'm beating my head against the wall-
after losing all my data, i'm setting up my 343 as a RAID5 unit. and have just gotten transmission running,
(sont get me started on the save-password issue)
but am having trouble gettin automatic running..
after some trouble i (think) its running.
but it doesnt seem to tell transmission what to do.
all the useris and passwords are correct in the config, and have even setup a n ezfeed where everything that comes off it should be what i want.
but -poof- nothing

is there a way to see whats its doing, and if i just screwed up the .conf file?

Thanx-
{and BTW- LOTS of info round here to learn with.. but STILL lots to learn.. hmm  }


DNS-343 1.04b03
4x 1.0T Seagate Barracuda 7200.11 RAID5 + 3TB external USB storage for occasional rsync backup.
Transmission-2.22-1 Automatic-0.6.4-1 netatalk-2.1.3-1 rsync-3.0.7-1 nano curl fortune screen SSH SSL SMBget wget
...and the all-powerful foo.sh smile

Offline

 

#266 2010-04-30 14:50:10

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

You could either enable logging within the startup script at /ffp/start/automatic.sh, or you could do a test run on the commandline:

Code:

$ automatic -f --once -v 2 -c /ffp/etc/automatic.conf | tee automatic.log

This will run Automatic in the foreground, logging level is raised to "2", and it will quit after it has processed the feeds you defined in /ffp/etc/automatic.conf once.
The ouput is shown on screen but is also saved to automatic.log (that's what the tool 'tee' is for).
Look over the logfile and see if there's any mention of an error or a warning.

If you can't figure out the problem yourself, you can send me the logfile (in that case, please re-run the above command with logging level 3, .i.e. "-v 3")

Offline

 

#267 2010-04-30 22:28:05

Darkman
Member
From: Sonoran Desert
Registered: 2010-04-23
Posts: 30

Re: [REL] Automatic for funplug-0.5

excellent!! that worked!
by changing the run level per your direction, i discovered that it didn't like "feed://"
it wants "HTTP://"
silly me.

now the problem is that i cant seem to get it to pull a file that i KNOW is in the feed...

in run level 3 i'm seeing it pull the feed, (30 items):

../src/automatic.c, 573: Checking feed 1 ...
../src/web.c, 401: [getHTTPData] url=http://www.some-site.rss/feed/, curl_session=(nil)
../src/web.c, 366: [am_curl_init] Created new curl session 0x26988
../src/regex.c, 95: [getRegExMatch] Text to match against: Content-Length: 24359
(23 byte)
../src/web.c, 95: Content-Length: 24359
../src/web.c, 438: [getHTTPData] response code: 200
../src/automatic.c, 428: [processFeed] curl_session=0x26988
../src/xml_parser.c, 87: 30 items in XML
../src/xml_parser.c, 130: == Done extracting RSS items ==
../src/automatic.c, 440: History bucket size changed: 60
../src/list.c, 228: [cleanupList] size before: 30
../src/list.c, 239: [cleanupList] size after: 0
../src/web.c, 570: [closeCURLSession] Closing curl session 0x26988
../src/automatic.c, 578: New bucket size: 60
[10/04/30 19:16:48] ../src/automatic.c, 128: Shutting down daemon
../src/list.c, 228: [cleanupList] size before: 1
../src/list.c, 239: [cleanupList] size after: 0
../src/list.c, 228: [cleanupList] size before: 0
../src/list.c, 239: [cleanupList] size after: 0
../src/list.c, 228: [cleanupList] size before: 7
../src/list.c, 239: [cleanupList] size after: 0

so i'm thinking its my filtering skills..?

this.is.the.format.(of)[the-file].torrent

and ive setup my filters thusly:
filter = { pattern => "this.is*the-file*"
           folder => "/mnt/HD_a2/some/arbitrary/folder"
         }

am i doing it wrong?


DNS-343 1.04b03
4x 1.0T Seagate Barracuda 7200.11 RAID5 + 3TB external USB storage for occasional rsync backup.
Transmission-2.22-1 Automatic-0.6.4-1 netatalk-2.1.3-1 rsync-3.0.7-1 nano curl fortune screen SSH SSL SMBget wget
...and the all-powerful foo.sh smile

Offline

 

#268 2010-04-30 22:38:30

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Yes, the pattern is not correct.

The regular expression '*' tells the regexp-parser that the character before the '*' may exist 0 or more times in the string.
In your case this is the letter 's' and the letter 'e'. So your filter will match these strings:

Code:

this.ithe-fil
this.isthe-fil
this.issthe-file
this.ithe-fileee
this.issssssssssthe-fileeeeeeeeeee

Obviously not what you want smile
Instead, you need to add a dot '.' in front of each '*' symbol. The dot is a placeholder for _any_ character, so it should match the file name you posted.

Code:

filter = { pattern => "this.is.*the-file.*"
           folder => "/mnt/HD_a2/some/arbitrary/folder"
         }

On a side note: Any kinds of brackets ([], () and {}) are special characters in a regular expression. If you want to explicitely match them in a file name (like your example above, you need to escape them with a backslash ( '\['). This way they're treated as normal characters.

Offline

 

#269 2010-04-30 23:25:13

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

I've updated Automatic to v0.6.1.
This new version just includes a tiny bugfix that was discovered by r2d290. If the cookies necessary for reading a feed are encoded within the URL using the :COOKIE: identifier, Automatic will now correctly parse these cookies.

Updated download link in the first post.

Offline

 

#270 2010-04-30 23:32:49

Darkman
Member
From: Sonoran Desert
Registered: 2010-04-23
Posts: 30

Re: [REL] Automatic for funplug-0.5

ok- i think i get it.

so if i want to grab something that may show up as :

This.is.what.i.want.torrent
or
this-is-what-i-want.torrent
or
thisiswhatiwant.torrent
(or any combination of those)

i would use :

Code:

filter = { pattern => "a.*pointless.*rant.*.torrent"
           folder => "/mnt/HD_a2/some/arbitrary/folder"
         }

am I correct?
I'm also assuming that these filters are not cAsE SenSItIVe


DNS-343 1.04b03
4x 1.0T Seagate Barracuda 7200.11 RAID5 + 3TB external USB storage for occasional rsync backup.
Transmission-2.22-1 Automatic-0.6.4-1 netatalk-2.1.3-1 rsync-3.0.7-1 nano curl fortune screen SSH SSL SMBget wget
...and the all-powerful foo.sh smile

Offline

 

#271 2010-04-30 23:36:59

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Yes, that filter is correct (although I would maybe drop the ".torrent" at the end since This might be omitted in the RSS feed as well).

And yes, the filtering is case insensitive.

If you set the logging level up to 4, the logfile will contain detailed info about the regexp match-making. Also, if you're using Windows, I suggest you download the freeware tool "The Regex Coach", where you can test every regular expression you can think of smile

Offline

 

#272 2010-04-30 23:55:51

Darkman
Member
From: Sonoran Desert
Registered: 2010-04-23
Posts: 30

Re: [REL] Automatic for funplug-0.5

actually- I'm running an osx/linux house.
I have win2kpro on one machine, just in case i need it... but it tends to live its life on the ubuntu side of the partition.
tho i might try 7 just for giggles if i'm ever bored.

so - I'll start my automatic (freshly updated smile ) and let it run for a while.
can i edit the conf file without bringing it down while i add new filters/feeds?

so i think the next step is to setup a scan folder to drop torrents in
I'm not sure where i would look for that info, however- any suggestions?

and incase i forgot-
many thanx for all your help... i'm trying to convince a few people to get one of these things and let me trick it out for them.. smile


DNS-343 1.04b03
4x 1.0T Seagate Barracuda 7200.11 RAID5 + 3TB external USB storage for occasional rsync backup.
Transmission-2.22-1 Automatic-0.6.4-1 netatalk-2.1.3-1 rsync-3.0.7-1 nano curl fortune screen SSH SSL SMBget wget
...and the all-powerful foo.sh smile

Offline

 

#273 2010-05-01 00:07:12

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Updating the config file without restarting Automatic unfortunately isn't possible yet, although it's on the list and probably the next thing I'm gonna tackle smile

Automatic itself doesn't have watchfolder functionality, but Transmission does:

Code:

$ transmission-daemon --help | grep watch
   -c   --watch-dir            <directory>     Directory to watch for new .torrent files
   -C   --no-watch-dir                         Disable the watch-dir

To activate it, shut down your current Transmission (and wait for half a minute or so, Transmission takes its time to quit), then start it from the commandline:

Code:

$ transmission-daemon -f -g /mnt/HD_a2/.transmission-daemon --watch-dir /mnt/HD_a2/my_torrents

Log messages should appear. Press Ctrl-C after a while to quit again. Transmission now remembered the watchfolder and will use it every time you start it up.
Use the startup script from now on to start Transmission.

Offline

 

#274 2010-05-01 02:20:19

Darkman
Member
From: Sonoran Desert
Registered: 2010-04-23
Posts: 30

Re: [REL] Automatic for funplug-0.5

well- that was pretty to look at for a few minutes.
smile
after killing it with ctrl-c  and waiting a minute to start it back up with the regular command,
it does nothing.

I'm not really sure why.

Code:

/ # ./ffp/start/transmission.sh status
transmission-daemon not running
/ # ./ffp/start/transmission.sh start 
Starting transmission-daemon
/ # ./ffp/start/transmission.sh status
transmission-daemon not running
/ #

"eet eez broke like movie of happy cowboyz"

how do i unbreak it?
tongue
i can call the transmission-daemon -g <path to conf> to get it running but the normal script seems broken now. (read as wont autostart on next reboot) hmm

did we inadvertantly change a pref somewhere i'm not aware of?

Last edited by Darkman (2010-05-01 02:41:49)


DNS-343 1.04b03
4x 1.0T Seagate Barracuda 7200.11 RAID5 + 3TB external USB storage for occasional rsync backup.
Transmission-2.22-1 Automatic-0.6.4-1 netatalk-2.1.3-1 rsync-3.0.7-1 nano curl fortune screen SSH SSL SMBget wget
...and the all-powerful foo.sh smile

Offline

 

#275 2010-05-01 03:52:42

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Check the owner of /mnt/HD_a2/.transmission-daemon

It should be owned by user "nobody", but if it's owned by "root" instead, then Transmission can't access it and would probably kill itself. I'm not too sure though.

You can change the owner of a folder with the command "chown".

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB