DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#76 2008-11-11 23:55:03

trepex
Member
Registered: 2008-11-09
Posts: 12

Re: [REL] Automatic for funplug-0.5

Fair enough, I'll sit tight smile  Thanks!

Offline

 

#77 2008-11-12 02:02:41

Muppet
Member
Registered: 2008-05-21
Posts: 44

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

Muppet wrote:

Unfortunately the one I have in mind is a private tracker that I cannot supply a link for.

Sorry for the late reply, I've been rather busy lately.

That said, I actually did get to test whether Automatic can deal with HTTPS feeds, and to my surprise, it can.
That's because libcurl is compiled with openssl linkage, so as long as that library is present on your system (it should, Transmission requires it), you can add HTTPS feeds to Automatic.

Please note that Automatic cannot handle authentication, however. So if your feed requires a password of some kind, this is not available (yet). I've been planning to add authentication/cookie handling, but couldn't think of a nice way to do it yet.

Thanks Kyle but I cannot get it to work on my https feed:

Code:

1 feed URLs
Read 9 patterns from config file
[load_state] Error: Unable to open statefile '//.config/automatic.state' for reading: No such file or directory
------ 08/11/12 10:51:21: Checking for new episodes ------
Checking feed 1 ...
[uploadData] Failed to upload to 'https://xxxx.yyyyyy.zzz/rss.php?feed=dl&cat=7,18&passkey=b01a33e7e94d0859a005d918c3c85309': Peer certificate cannot be authenticated with known CA certificates

I believe the site uses a self-signed certificate. I found a reference to a similar problem here which looks like it has a solution:

Code:

curl_setopt($connection, CURLOPT_SSL_VERIFYPEER, false);

But I guess it will require you to compile a new version.

Last edited by Muppet (2008-11-12 02:03:33)

Offline

 

#78 2008-11-27 00:43:11

Muppet
Member
Registered: 2008-05-21
Posts: 44

Re: [REL] Automatic for funplug-0.5

Kyle, any chance of recompiling with that change above?

Offline

 

#79 2008-11-27 00:53:11

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

I've already made the necessary changes. Give me until the weekend, unfortunately I won't have the time to release it any earlier.

Offline

 

#80 2008-11-27 01:40:01

Muppet
Member
Registered: 2008-05-21
Posts: 44

Re: [REL] Automatic for funplug-0.5

Thanks and take your time, there is no rush

Offline

 

#81 2008-11-27 22:07:46

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

This is exactly the program I need. Kudos to you for writing it.

I have followed the instructions to install transmission and automatic.
I am able to see the transmission interface via a web page.
I renamed automatic.conf-sample to automatic.conf

Nothing seems to be happening when I add torrents to the rss feed. I never see them show up in transmission.

Im using telnet in windows vista to connect to my NAS and it doesnt support copy paste. What info would you all need to help me diagnose this problem?

This is what I have changed in the config file:

i took the # out from the front of the rpc-host and changed that line to read
rpc-host = 127.0.0.1

i took the # out from the front of rpc-port

url = "www.mytorrenturl.com"

interval = 1

torrent-folder = "/mnt/HD_a2/Media/Downloads/Torrents"


everything else has been left alone

Offline

 

#82 2008-11-28 00:03:32

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Well, that's not all that much information, but I assume you forgot to add filters to the "pattern" variable.
Automatic won't simply download every torrent that's in the feed, you will have to tell it what to download.

So, for example, if you want to download something that might have the word "That One Film" in the name, you create a filter:

Code:

patterns = { "That One Film"
}

You can create multiple filters, just like it is shown in the sample file. Automatic expects regular expressions as filters, which help with downloading repeating content, like TV episodes.


If that doesn't help, you can also  enable logging by editing the file 'automatic.sh' in /ffp/start. Remove the # from the necessary lines (there's instructions in the file) and then restart Automatic.

It'll create a logfile at a given path (you can edit that path in the file as well).

Offline

 

#83 2008-11-28 16:57:35

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

In patterns am I able to use "*" to indicate that everything in this feed should be downloaded?

Also if I add a new feed that contains 5 items, those 5 should show up in transmission almost immediately correct?

Last edited by lividhatter (2008-11-28 17:05:01)

Offline

 

#84 2008-11-28 17:00:47

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Since it's regular expressions, you need to use ".*"
Then it will download every item in the feed you provied.

Offline

 

#85 2008-11-28 17:13:47

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

That was the problem! Thank you so much for your patience Kylek.

Now to figure out why it pauses every download and says "no such file or directory."

Offline

 

#86 2008-11-28 19:11:58

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Start automatic on the console with verbose output enabled:

Code:

/ffp/bin/automatic -f -c /ffp/etc/automatic.conf -v 2

It should give you some hint as to what is not working.

Offline

 

#87 2008-11-29 04:53:40

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

everything looked fine until I hit control+c to stop it.

I get this message:
Error: Unable to open state file '//.config/automatic.state' for writing: No such file or directory

Where do i need to create this file?

Do you think this has to do with ownership? I know my torrent folder and my download folder are both owned by nobody, I am not sure about transmission though.

Last edited by lividhatter (2008-11-29 05:05:04)

Offline

 

#88 2008-11-29 05:32:29

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

looks like the transmission folder is also owned by nobody.

Offline

 

#89 2008-11-29 17:52:35

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Looks like you haven't changed the option "statefile" in /ffp/etcautomatic.conf
When accessing the NAS via Telnet, you don't have no home folder, which results in the weird path you mentioned above. Set it to a directory that exists. I personally use the settings folder of Transmission:

Code:

statefile = "/mnt/HD_a2/.transmission-daemon/automatic.state"

Offline

 

#90 2008-11-29 18:52:36

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Updated Automatic to v0.3. As always, links and changelog have been updated in the first post.

Please read the first post carefully again, the format for patterns has changed a bit, and you also have to install an additional library. Details are on page 1.


Have fun!

Offline

 

#91 2008-11-29 20:44:29

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

Ok i dont receive that error when i close automatic after running it in the foreground. (But my transmission still has the error when a torrent is open for more then a few seconds). I will go post over there. Thank you KyleK.

Offline

 

#92 2008-11-30 22:25:18

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

Ok Kylek everything seems to be working, but files keep getting re-added. Then they verify all the way to 100% so i delete them and a few minutes later they are back.

Offline

 

#93 2008-11-30 22:30:36

lividhatter
Member
Registered: 2008-11-27
Posts: 26

Re: [REL] Automatic for funplug-0.5

when i run automatic in verbose mode it eventually says [add_to_bucket] bucket gets too large (10), deleting head item...

then nothing

It seems like its not detecting duplicates for some reason. What detail do you need to help me get this working?

Last edited by lividhatter (2008-11-30 22:52:32)

Offline

 

#94 2008-12-01 11:12:37

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

The history list is supposed to gro as large as there are items in your feed(s). 10 is just the default value. It's hard to say why it doesn't get larger.
Try running with argument "-v 2" for more verbose output.

Offline

 

#95 2008-12-01 23:24:36

Muppet
Member
Registered: 2008-05-21
Posts: 44

Re: [REL] Automatic for funplug-0.5

Kyle, just confirming that the change to allow the self-signed SSL certificate works. Thanks heaps.

Offline

 

#96 2008-12-03 01:36:21

Muppet
Member
Registered: 2008-05-21
Posts: 44

Re: [REL] Automatic for funplug-0.5

It seems any torrents added via automatic start downloading immediately, even if I have set transmission to not start downloading uploaded torrents. I would rather eyeball the torrents to ensure my regex has snatched the correct thing before downloading them. Is this due to something automatic is doing, or a bug in transmission itself? I took a look at the source code for automatic but could not find anywhere it was issuing a command to start the torrent being uploaded.

Offline

 

#97 2008-12-03 06:09:14

secrice
Member
Registered: 2008-03-13
Posts: 5

Re: [REL] Automatic for funplug-0.5

Hi,

Please check this URL. http://rss.thepiratebay.org/101
Automatic 0.3 displays, "Is this really a torrent feed?"

Can't I use this URL?

Offline

 

#98 2008-12-03 15:02:34

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Muppet wrote:

It seems any torrents added via automatic start downloading immediately, even if I have set transmission to not start downloading uploaded torrents. I would rather eyeball the torrents to ensure my regex has snatched the correct thing before downloading them. Is this due to something automatic is doing, or a bug in transmission itself? I took a look at the source code for automatic but could not find anywhere it was issuing a command to start the torrent being uploaded.

Automatic doesn't do anything special, it just sends a "torrent-add" command with the torrent data as metainfo.
I could add the optional "paused:true/false" argument, but I don't want to do that.

How exactly have you set Transmission to not start downloading new torrents?

Offline

 

#99 2008-12-03 15:16:11

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

A fast follow-up: I found the global preference in the gtk build (and it's probably also available in the Mac build), but it's not in the daemon (or even libtransmission).

This means even if you set the limit, adding a torrent either via web interface or Automatic will ignore your "do not start" preference.

There's not that much I can do about it, but I might be able to submit a patch to Transmission that adds the functionality to the server.

Offline

 

#100 2008-12-03 22:56:37

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

secrice wrote:

Hi,

Please check this URL. http://rss.thepiratebay.org/101
Automatic 0.3 displays, "Is this really a torrent feed?"

Can't I use this URL?

The feed should work just fine with Automatic. That message is a debug message I forgot to remove.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB