DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#201 2010-01-20 19:47:53

nyunyu
Member
Registered: 2009-05-03
Posts: 44
Website

Re: [REL] Automatic for funplug-0.5

Is there a way for this script to identify torrents being download and deny other downloads with the same name?

Like in the configuration I chose to download
patterns =  {
              "Heroes.*S0[3-9]E.*720p"
              "House.*S0[6-9]E.*720p"
            }

So, if the scripts sees Heroes S03E14 being downloaded, it just denies every other S03E14 torrents.
I ask this because I sees that the script often download duplicate torrents with a bit of difference in its name.

Hope I do make the statement clear.


DNS323 + 2x1TB WD GREEN + Fun Plug 0.5 (Fonz) + Transmission 1.92 + Automatic 0.6 = GREAT!
Looking for Auto Direct Download script if possible smile

Offline

 

#202 2010-02-15 22:16:36

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Hey guys,

version 0.5 of Automatic is out. It only has one major and a couple of minor bugfixes, and you can enable proper logging now with a commandline parameter. Sorry, no password-protected rss feeds yet.

Enjoy and let me know if something is wrong.

Cheers!

Offline

 

#203 2010-02-16 03:18:44

nyunyu
Member
Registered: 2009-05-03
Posts: 44
Website

Re: [REL] Automatic for funplug-0.5

Kylek, about my message above...any reply? smile
Thanks.


DNS323 + 2x1TB WD GREEN + Fun Plug 0.5 (Fonz) + Transmission 1.92 + Automatic 0.6 = GREAT!
Looking for Auto Direct Download script if possible smile

Offline

 

#204 2010-02-21 21:07:20

Headcase_Fargone
Member
Registered: 2009-11-06
Posts: 44

Re: [REL] Automatic for funplug-0.5

There a wiki anywhere for installing and setting up Automatic?  I've looked through every page of this thread and I see a few people running into the same issues I am, but nothing's working for me.

At first I kept getting automatic.state not found errors, so I eventually had to just create an automatic.state file in my Transmission folder with nothing but a # in it.  That seemed to get rid of that error.

Now no matter what RSS feed I try I get something like the following:

[10/02/21 19:03:32] ../src/automatic.c, 503: Daemon started
../src/automatic.c, 522: 1 feed URLs
../src/automatic.c, 523: Read 7 patterns from config file
../src/state.c, 111: Restored 0 old entries
../src/xml_parser.c, 170: Error: Unable to parse input data!

I assume that means it's successfully connecting to the RSS feed and actually finding matches and it's just unable to do anything with the resulting torrents?  Or am I way off-base here?

Offline

 

#205 2010-02-21 23:11:55

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

The automatic.state file will get created if it doesn't already exist. The warning shouldn't bother you.

That last line of the log however means that libxml wasn't able to parse the XML file. Can you tell me what feeds you tried?

Offline

 

#206 2010-02-21 23:14:03

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

nyunyu wrote:

Kylek, about my message above...any reply? :)
Thanks.

I'm afraid Automatic isn't THAT smart yet, to figure out that a similar file has already been added to Transmission.
The only way to prevent double downloads currently is to either choose your feeds carefully, and/or create patterns that only download one release but not the other.

Offline

 

#207 2010-02-21 23:38:42

Headcase_Fargone
Member
Registered: 2009-11-06
Posts: 44

Re: [REL] Automatic for funplug-0.5

http://www.bt-chat.com/

I've also tried http://www.ezrss.it/ to no avail.

Offline

 

#208 2010-02-22 00:37:22

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Can you send me your automatic.conf? The adress is 1100101+automatic<at>gmail.com

Offline

 

#209 2010-02-23 23:46:23

Headcase_Fargone
Member
Registered: 2009-11-06
Posts: 44

Re: [REL] Automatic for funplug-0.5

Sent it off a couple of days ago.  Did you receive it?  No rush at all in looking into it, just making sure you got it.

I know I'm doing something wrong here, just frustrating me that I can't figure out what.

Offline

 

#210 2010-02-23 23:50:46

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Yes, I'm sorry I haven't responded yet, work is taking a bit of my time currently. I'll try to have a look at it tomorrow.

Offline

 

#211 2010-02-23 23:53:40

Headcase_Fargone
Member
Registered: 2009-11-06
Posts: 44

Re: [REL] Automatic for funplug-0.5

Like I said, no rush at all.  Just making sure it didn't get lost in the ether.  Thanks again for being so responsive.

Offline

 

#212 2010-03-02 13:37:32

jmcqup
Member
From: Uganda
Registered: 2008-06-17
Posts: 23

Re: [REL] Automatic for funplug-0.5

After replacing my hard drives and reinstalling Automatic I am no longer able to retrieve feeds (Connection time out), though Transmission is working fine. Wget is also not working... Any ideas what I may have changed? thanks -james

Offline

 

#213 2010-03-02 15:14:10

Headcase_Fargone
Member
Registered: 2009-11-06
Posts: 44

Re: [REL] Automatic for funplug-0.5

So I woke up this morning expecting to find a particular torrent had been downloaded but to my dismay nothing.  I checked and Automatic was running, and it had worked like a charm last week for the same show with the same regular expression.  Nothing this week though.

So I restart Automatic and voila.  It instantly finds and starts the torrent.  Any idea what would cause that?

Offline

 

#214 2010-03-02 21:27:38

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Hm, that is a good question. The logfile might have been of help, but I'm afraid it got overwritten when you restarted Automatic.
How long had Automatic been running until you noticed this?

If this happens again please let me know (and send me the logfile).

Last edited by KyleK (2010-03-02 21:28:08)

Offline

 

#215 2010-03-02 21:29:10

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

jmcqup wrote:

After replacing my hard drives and reinstalling Automatic I am no longer able to retrieve feeds (Connection time out), though Transmission is working fine. Wget is also not working... Any ideas what I may have changed? thanks -james

Maybe the feed you're using is currently not available? Other than that I see no connection between changing a harddrive and Automatic, or even wget.

Offline

 

#216 2010-03-02 21:35:03

Headcase_Fargone
Member
Registered: 2009-11-06
Posts: 44

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

Hm, that is a good question. The logfile might have been of help, but I'm afraid it got overwritten when you restarted Automatic.
How long had Automatic been running until you noticed this?

If this happens again please let me know (and send me the logfile).

It had been running for seven days, and automatically downloaded probably five files in that time period. 

I'll be sure to grab a copy of the log before restarting if it happens again.

Offline

 

#217 2010-03-03 12:32:31

jmcqup
Member
From: Uganda
Registered: 2008-06-17
Posts: 23

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

jmcqup wrote:

After replacing my hard drives and reinstalling Automatic I am no longer able to retrieve feeds (Connection time out), though Transmission is working fine. Wget is also not working... Any ideas what I may have changed? thanks -james

Maybe the feed you're using is currently not available? Other than that I see no connection between changing a harddrive and Automatic, or even wget.

I'm stumped. The feeds are http://www.ezrss.it/feed/ and http://rss.thepiratebay.org/205 so I doubt they are down.
For what it is worth I can ping http://www.ezrss.it/feed/... I assumed the other has it turned off.
Anything, anything I can try??

-j

Offline

 

#218 2010-03-03 19:14:07

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Can you ping these domains? What about 'traceroute'?
What's really strange is that Transmission works, but Automatic and wget don't. This looks like a network problem than anything else.

Offline

 

#219 2010-03-03 19:20:39

andrew5368
Member
Registered: 2009-12-28
Posts: 41

Re: [REL] Automatic for funplug-0.5

Finally got round to setting this up, great tool, thanks alot! Can't believe the transmission guys won't implement this feature..

Offline

 

#220 2010-03-05 23:50:41

NagyBandi
New member
Registered: 2010-03-05
Posts: 3

Re: [REL] Automatic for funplug-0.5

Hi!

I just installed 0.5 and I'm having a problem with the extension of the downloaded torrent files. When downloaded, the extension is saved as .torrent" (with a qoute at the end) and so the transmission won't grab it from the watched directory. I haven't used any older versions of the automatic, so I don't know if this is a new problem or not.

Looking into the log file I found this:

../src/web.c, 401: [getHTTPData] url=http://aaa.aa/download.php?passkey=123&id=000, curl_session=0x12345
../src/regex.c, 97: [isMatch] Text to match against: Content-Disposition: attachment; filename="%5Baaa_%23123456%5DBlablabla.torrent"
(108 byte)
../src/web.c, 111: [write_header_callback] Found filename: %5Baaa_%23123456%5DBlablabla.torrent"

So itt appears as though there is an error when parsing torrent file names with regex. The %5B and such stuff is there because the file name contains brackets and a hash mark, so it should look like this: [aaa_#123456]Blablabla.torrent
This is not the about the regex pattern in the config file, that works fine. The RSS XML is downloaded OK, and it finds the download link just fine. The problem seems to arise when downloading the actual torrent file. But just in case, here's my pattern:
patterns =  { ".*"
                   }

It's a personalized RSS feed so I want to download every torrent in it.

Can somebody please help me with this problem?

Thanks in advance,
Bandi

Last edited by NagyBandi (2010-03-05 23:53:31)

Offline

 

#221 2010-03-06 01:00:36

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

@NagyBandi
That is indeed a bug in Automatic, thanks for reporting! I've already found the issue and it should be easy to fix. I intend to release an update later this weekend.

On another note: You mention that you save the torrents to Transmissions watchfolder so it starts downloading it. May I ask why you don't use the ability to let Automatic add the torrent to Transmission directly via RPC?

The watchfolder of Transmission has a serious disadvantage on the DNS-323/CH3SNAS: Since the device doesn't have (proper) inotify support,  Transmission manually scans the watchfolder every single second for changes. This means the drive will never go to sleep even if there's nothing to new to download for a longer timespan.

Offline

 

#222 2010-03-06 02:17:43

NagyBandi
New member
Registered: 2010-03-05
Posts: 3

Re: [REL] Automatic for funplug-0.5

Hi!

Thanks for a quick reply and for the warning about this drawback! I chose to use the watchfolder because I use it anyway for other reasons. I figured the simplest way to start a new torrent in a non-automated way is to save the torrent file to the watchfolder when downloading it from the internet. That way I don't have to download the torrent file somewhere and then go to the web interface of the Transmission (I'd like to keep the torrent client of my desktop machine as the default client). And since I use it already for this reason, I thought it would be best to use the Automatic this way, too.
To be honest I didn't really have time to get a grasp on the DNS-323 world yet, since I only bought the stuff yesterday. Oddly, I've noticed the disks going to sleep a few times but I guess it was before I started setting up Transmission. I was planning to try the RPC way but got busy doing other stuff, like getting the Transmission to start working again (oh yeah, I'm sort of a newbie to linux too smile ). Currently it can't start any new downloads but has no problem finishing the ones it has already started smile

Thanks again for the reply!

Offline

 

#223 2010-03-07 13:35:15

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

I updated Automatic to v0.5.1, fixing the bug that NagyBandi reported. Check the first post of this thread for the download link.

Offline

 

#224 2010-03-08 10:08:23

NagyBandi
New member
Registered: 2010-03-05
Posts: 3

Re: [REL] Automatic for funplug-0.5

Thanks for fixing it in such a timely fashion! I'll download and try it when I get home.

edit:
I'm still having the same problem sad Being a linux noob I could really use some confirmation that I indeed have the latest version. What I did was:
- remove v0.5 with funpkg -r /ffp/pkg/Automatic-0.5-1.tgz . After that, there was no longer any automatic in my /ffp/bin.
- download the newest version with wget http://kylek.is-a-geek.org:31337/files/ … .5.1-1.tgz . When I was done with this, I had both .tgz files sitting in my /etc/pkg directory.
- install new version with funpkg -i /ffp/pkg/Automatic-0.5.1-1.tgz . Now I again have automatic in my /ffp/bin , dated March 7, 12:23
- edited the newly created /ffp/start/automatic.sh to enable logging
- started it with sh /ffp/start/automatic.sh start
- if I enter funpkg -u /ffp/pkg/Automatic-0.5.1-1.tgz , I get a reply saying it is already installed ( "Skipping Automatic-0.5.1-1.tgz (already installed)" ).

If I add another torrent to my rss feed, it is downloaded but its extension is .torrent" .

Is there any way to query the actual version of the installed automatic?

It did start logging into /mnt/HD_a2/.transmission-daemon/automatic.log . The log reads:

[10/03/09 20:44:08] ../src/automatic.c, 503: Daemon started
../src/automatic.c, 522: 1 feed URLs
../src/automatic.c, 523: Read 1 patterns from config file
../src/state.c, 111: Restored 1 old entries
[10/03/09 20:44:08] ../src/automatic.c, 383: Found new download: Some.Linux.Iso (http://aaaaa.aa/dl.php?pk=12345&id=67890)
../src/state.c, 66: Saving state (2 downloaded torrents) to disk

I could try and get the actual reply to the http request for downloading the torrent file from code, if that would help with the debugging. I'll also try compiling your code on my desktop machine to do some debugging myself, but not having used C in almost a decade now, I expect to have some difficulties smile

Thanks in advance for any reply!
Bandi

Last edited by NagyBandi (2010-03-09 22:11:51)

Offline

 

#225 2010-03-27 17:36:56

krystian
Member
Registered: 2008-07-10
Posts: 7

Re: [REL] Automatic for funplug-0.5

Hi

I wonder if Automatic supports particular scenario. The RSS I use is just a RSS that has links to pages, later that pages have a link in them to a torrent (among other things).
I tried to test Automatic but I suppose it treated the original page as torrent file and wanted to upload it to Transmission...

Is there any way to support my scenario?
I suppose some MIME type should help differentiate between the two.

Thanks in advance

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB