DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2007-12-29 22:16:32

petasis
Member
Registered: 2007-06-23
Posts: 39

Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Dear all,

The subversion package has been updated to 1.4.6. Please find installation instructions at the wiki:

http://dns323.kood.org/howto:subversion:fun_plug_native

Regards,

George

Offline

 

#2 2008-01-22 00:12:49

danjo
New member
Registered: 2008-01-22
Posts: 2

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Hello,

Im having some trouble with this package:

/ # svn
R_ARM_PC24: Compile shared liraries with -fPIC

, using fonz fun_plug 0.3 and firmware 1.03. Anyone has any ideas?

Cheers,

-- Daniel

Offline

 

#3 2008-01-22 02:53:53

petasis
Member
Registered: 2007-06-23
Posts: 39

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Have you followed the installation instructions from:
http://dns323.kood.org/howto:subversion:fun_plug_native ?

Offline

 

#4 2008-01-22 12:00:00

HaydnH
Member
Registered: 2007-09-28
Posts: 187

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

"R_ARM_PC24: Compile shared liraries with -fPIC"

One of the shared libraries used by svn either wasn't compiled with -fPIC set in the CFLAGS environment variable or configured with the appropriate PIC flag. I would assume it's working for Petasis as he's probably using different libraries that were compiled differently (i.e: copied the binary to the dns-323 and used existing libraries) - "ldd svn" will tell you what libraries are used by svn.

Offline

 

#5 2008-01-22 12:39:39

fonz
Member / Developer
From: Berlin
Registered: 2007-02-06
Posts: 1716
Website

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

I've seen this myself, and rechecked funplug-0.3 and -0.4 files. They seem fine. For those making packages, to check your files for this type of bug, you can do the following:

Code:

cd /path/to/your/installed/files
for f in $(find -type f -name \*.so\*); do echo "XX $f"; arm-linux-uclibc-readelf -a $f | grep PC24; done | less

If for any .so file, there is output like "000001f0  00000201 R_ARM_PC24 ...", it's broken.

Offline

 

#6 2008-01-22 13:03:41

bfg100k
Member
Registered: 2007-09-15
Posts: 55

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Hi, I'm a new user with svn (was on cvs till now smile). with regards to the authentication, is it possible to switch to using the OS users rather than depending on the plain text passwd file? If so, how? Thanks

Offline

 

#7 2008-01-22 13:19:53

HaydnH
Member
Registered: 2007-09-28
Posts: 187

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Fonz - nice command

Offline

 

#8 2008-01-22 21:40:27

danjo
New member
Registered: 2008-01-22
Posts: 2

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

After running fonz convenient little shell script the culprit seems to be the libsvn_ra_dav library. Anyone else get this or have I screwed up during installation? I started cross compiling svn here locally, but it seems like it may take some time. Anyone beats me to it? smile

Cheers,

-- Daniel

Offline

 

#9 2008-03-15 11:26:51

kh_naba
Member
Registered: 2008-03-08
Posts: 13

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

danjo wrote:

After running fonz convenient little shell script the culprit seems to be the libsvn_ra_dav library. Anyone else get this or have I screwed up during installation? I started cross compiling svn here locally, but it seems like it may take some time. Anyone beats me to it? smile

Cheers,

-- Daniel

So would you share your binary? I have the same error and waiting for someone provide a fixed version.

Thanks.

Regards,
-Naba

Offline

 

#10 2008-03-15 11:55:47

sjmac
Member
Registered: 2008-01-21
Posts: 222

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

The svn in the optware feed seems to work OK. (I just tested it for svn checkout ...)

See the instructions for installing binaries in this thread
http://dns323.kood.org/forum/t1797-%5Ba … k%27s.html

I think you might need to go over to page two to get the tips for configuring ipkg.conf, but when it's done you just need to type
ipkg install svn

Offline

 

#11 2008-03-15 11:58:47

sjmac
Member
Registered: 2008-01-21
Posts: 222

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Copied here:

oxygen wrote:

cd /mnt/HD_a2/
mkdir ipkg
cd ipkg
wget http://ipkg.nslu2-linux.org/feeds/optwa … -9_arm.ipk
tar -xzf ipkg-opt_0.99.163-9_arm.ipk
tar -xzf data.tar.gz
mkdir /opt
mount --bind /mnt/HD_a2/ipkg/opt /opt
export PATH=/opt/bin:/opt/sbin:$PATH

jules wrote:

To configure that feed as the default feed, just add in /opt/etc/ipkg.conf
src dns323 http://ipkg.nslu2-linux.org/feeds/optwa … /unstable/

Then launch "ipkg update"

For a complete list of available packages type: "ipkg list"
The first string displayed is an alias that can be used to install packages ie. "ipkg install wget" , this will install wget_1.11-1_arm.ipk and all the required dependecies.

ipkg remove <name> is also useful :-)

Last edited by sjmac (2008-03-15 12:00:09)

Offline

 

#12 2008-03-21 15:03:26

wonko
Member
Registered: 2008-03-21
Posts: 11

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Hi all,

question from a linux noob:

I get the following error when starting svnserve:

/mnt/HD_a2/fun_plug.d/start # svnserve start
svnserve: '/mnt/HD_a2/fun_plug.d/lib/libsvn_repos-1.so.0' is not an ELF file
svnserve: can't load library 'libsvn_repos-1.so.0'

Firmware: 1.03
funplug: 0.3


Any idea what might be the cause of this ?


Thanks,

Matthias.

Offline

 

#13 2008-03-21 15:08:50

fonz
Member / Developer
From: Berlin
Registered: 2007-02-06
Posts: 1716
Website

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

wonko wrote:

svnserve: '/mnt/HD_a2/fun_plug.d/lib/libsvn_repos-1.so.0' is not an ELF file

If it's not ELF, what is it then? Run

Code:

file /mnt/HD_a2/fun_plug.d/lib/libsvn_repos-1.so.0

Offline

 

#14 2008-03-21 16:24:21

wonko
Member
Registered: 2008-03-21
Posts: 11

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

Hi,

this is what I get:

/mnt/HD_a2/fun_plug.d/lib/libsvn_repos-1.so.0: ASCII text, with no line terminators


Maybe the issue is related to using total commander to unpack that svn archive.
I'll try again directly on my nas. Will keep you posted.


Thanks,

Matthias.

Offline

 

#15 2008-03-21 16:59:32

wonko
Member
Registered: 2008-03-21
Posts: 11

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

yep, that was it. seems to work fine now.

Thanks a bunch.

Offline

 

#16 2008-03-23 22:06:05

uyuni
Member
From: Denmark
Registered: 2007-12-29
Posts: 31

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

kh_naba, did you succeed in your SVN compilation? If yes, could you upload the libsvn_ra_dav somewhere?
Or are everybody using SVN from the optware feed now?
BTW, I checked the subversion-1.4.5 package and apparently it too was compiled without the fPIC flag :-(


D-Link DNS-323 firmware 1.08 + Samsung HD203WI + Samsung HD103UJ + ffp-0.5 + addons

Offline

 

#17 2008-03-23 23:01:09

oxygen
Member
Registered: 2008-03-01
Posts: 320
Website

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

i compiled subversion with fonz' fun_plug 0.5 toolchain without problems.
just get subversion-*.tar.gz and subversion-deps-*.tar.gz, extract both and ./configure --prefix=/ffp --with-ssl && make && make install && make clean should work.

Offline

 

#18 2008-03-29 11:08:27

uyuni
Member
From: Denmark
Registered: 2007-12-29
Posts: 31

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

What is the memory penalty for running funplug 0.5 compared to the previous ones? I mean with funplug 0.5 you have a new, separate set of shared libraries in RAM next to the DNS323 built-in ones. That must consume more RAM but how much?

This is the only reason I haven't switched to funplug 0.5 yet... I really don't think we're swamped in RAM on the DNS323, you know ;-)


D-Link DNS-323 firmware 1.08 + Samsung HD203WI + Samsung HD103UJ + ffp-0.5 + addons

Offline

 

#19 2008-04-21 16:42:50

5h4rk
Member
Registered: 2008-01-26
Posts: 27

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

I'm having this problem:


/mnt/HD_a2# svnadmin create svn
svnadmin: can't load library 'libaprutil-1.so.0'

Firmware: 1.04
funplug: 0.5

Last edited by 5h4rk (2008-04-21 16:43:31)


FFP 0.5 | FW 1.0.5

Offline

 

#20 2008-04-21 18:47:21

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

subversion depends on libapr and libaprutils. You can get both pacakges at fonz' site: http://www.inreto.de/dns323/fun-plug/0.5/packages/

Download them to your DNS-323 and install them by issuing the command "funpkg -i apr.xxx.tgz apr-util.xxx.tgz"  (I don't have the correct file names right now, you'll figure it out smile

Offline

 

#21 2008-04-22 00:54:26

fonz
Member / Developer
From: Berlin
Registered: 2007-02-06
Posts: 1716
Website

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

don't forget neon.

Offline

 

#22 2008-04-22 02:45:42

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

uyuni wrote:

What is the memory penalty for running funplug 0.5 compared to the previous ones? I mean with funplug 0.5 you have a new, separate set of shared libraries in RAM next to the DNS323 built-in ones. That must consume more RAM but how much?

This is the only reason I haven't switched to funplug 0.5 yet... I really don't think we're swamped in RAM on the DNS323, you know ;-)

That is a nice question, actually. I've been running 0.5 for a while now, and I haven't had any problems. Still, it'd be nice to know if all the additional libraries would cause RAM problems.
(btw, this is so not the correct topic for this question :p)

Offline

 

#23 2008-04-22 05:33:29

5h4rk
Member
Registered: 2008-01-26
Posts: 27

Re: Subversion 1.4.6 for fonz fun_plug 0.3 NOW AVAILABLE...

KyleK wrote:

subversion depends on libapr and libaprutils. You can get both pacakges at fonz' site: http://www.inreto.de/dns323/fun-plug/0.5/packages/

Download them to your DNS-323 and install them by issuing the command "funpkg -i apr.xxx.tgz apr-util.xxx.tgz"  (I don't have the correct file names right now, you'll figure it out smile

Thanks! Now I can create but not start the server:

root@nas:/mnt/HD_a2# sh ./ffp/start/svnserve.sh restart
killall: svnserve: no process killed
ERROR: svnserve not found or not executable
root@nas:/mnt/HD_a2#


FFP 0.5 | FW 1.0.5

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB