DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#676 2012-06-09 17:00:58

36963
New member
Registered: 2012-06-09
Posts: 3

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

Most Linux software requires the autotools suite in order to properly
compile. The most important tools here are autoconf and automake. I'm sure they're available for your system as well.

[root@MyBookWorld etc]# automatic -f
../src/automatic.c, 561: Automatic version: 0.7.2 (3acd9b3)
../src/automatic.c, 578: 2 feed URLs
../src/automatic.c, 579: Read 1 filters from config file
../src/state.c, 111: Restored 5 old entries
../src/regex.c, 29: [init_regex] PCRE compilation failed at offset 0: nothing to repeat (pattern: *)
Entity: line 1: parser error : Start tag expected, '<' not found
missing user id
^
../src/xml_parser.c, 175: Error: Unable to parse input data!


Hi guys, so I installed automatic 0.7.2, but when I stared, it showed above. Could you tell me what's the problem with it. My nas is hacked mybookworld II. Thanks!

Offline

 

#677 2012-06-09 23:18:22

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

One of your regular expressions is wrong. The regex pattern "*" is not a valid pattern. Try ".*" instead.

Also, make sure the rss feed provides a valid RSS (XML) file. Currently, that does not seem to be the case.

Last edited by KyleK (2012-06-09 23:19:36)

Offline

 

#678 2012-06-10 04:20:59

36963
New member
Registered: 2012-06-09
Posts: 3

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

One of your regular expressions is wrong. The regex pattern "*" is not a valid pattern. Try ".*" instead.

Also, make sure the rss feed provides a valid RSS (XML) file. Currently, that does not seem to be the case.

Thank you! I will try to fix it.

Offline

 

#679 2012-06-10 04:39:21

36963
New member
Registered: 2012-06-09
Posts: 3

Re: [REL] Automatic for funplug-0.5

KyleK wrote:

One of your regular expressions is wrong. The regex pattern "*" is not a valid pattern. Try ".*" instead.

Also, make sure the rss feed provides a valid RSS (XML) file. Currently, that does not seem to be the case.

WOWOWOOWOW! It's working now! So kind of you! You are my hero!~ Thank you again!

Offline

 

#680 2012-06-11 14:09:27

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

where is the automatic logfile located by default?

Offline

 

#681 2012-06-11 14:14:05

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

If nothing is specified on the commandline when starting the daemon, automatic logs to stderr. Which, in daemon-mode, goes into the nirvana.

If you use one of the funplug packages from the first post, and use /ffp/start/automatic.sh to start/stop Automatic, then it logs to /mnt/HD_a2/.transmission-daemon/automatic.log (this is specified in /ffp/start/automatic.sh)

Offline

 

#682 2012-06-11 14:21:05

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

thanks for the quick response Kylek......
Forgive me as i'm a complete noob with Linux, what does this mean?

[12/06/11 04:03:05] ../src/automatic.c, 584: Daemon started
../src/automatic.c, 589: Automatic version: 0.7.3 (3367e1a)
../src/automatic.c, 606: 1 feed URLs
../src/automatic.c, 607: Read 1 filters from config file
../src/state.c, 100: [load_state] Error: Unable to open statefile '//.config/automatic.state' for reading: No such file or directory
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)
../src/web.c, 422: [getHTTPData] '': URL using bad/illegal format or missing URL (retval: 3)


this is part of my conf file, ithink in relation to above:

feed =  {  url     => "http://kat.ph/movies/?rss=1"
           cookie  => ""
           id      => 1
        }

Offline

 

#683 2012-06-11 14:29:29

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Your feed URL is empty for some reason. Have you restarted Automatic after editing the automatic.conf file?

Offline

 

#684 2012-06-12 13:07:58

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

ok so i managed to create a blank statefile and now i'm getting this:

../src/automatic.c, 589: Automatic version: 0.7.3 (3367e1a)
../src/automatic.c, 606: 1 feed URLs
../src/automatic.c, 607: Read 1 filters from config file
../src/state.c, 111: Restored 0 old entries
../src/xml_parser.c, 175: Error: Unable to parse input data!

Note it says 1 feed url and 1 filter, but i have set 2 url and filters

Offline

 

#685 2012-06-12 16:45:42

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Hm. Your site sends the RSS data in a compressed form, but apparently Automatic is not configured to deal with incoming HTTP content that's compressed.
I'm surprised that nobody has run into that issue before.

I've fixed the issue, it'll be in the next release.

Offline

 

#686 2012-06-12 16:52:32

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

Im not sure, I have setup 2 feeds and just 1 gets parsed. Im not even sure if ive got it to run properley.

Offline

 

#687 2012-06-12 16:54:18

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Send me your config file via email, I'll have a look.

Offline

 

#688 2012-06-12 17:17:25

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

ive also noticed that :
transmission-home = "~/.config/transmission"

whereas my transmission home is (in /ffp/start/transmission.sh):

TRANSMISSION_HOME=/i-data/md0/admin/transmission

Offline

 

#689 2012-06-14 10:08:31

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

m3cab wrote:

ive also noticed that :
transmission-home = "~/.config/transmission"

whereas my transmission home is (in /ffp/start/transmission.sh):

TRANSMISSION_HOME=/i-data/md0/admin/transmission

'transmission-home' is an option from "very the old days" auf Automatic & Transmission.
You can ignore it, unless you use a really old version of Transmission (pre-1.3).

Offline

 

#690 2012-06-14 10:52:21

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Ok guys, release time! I've finished work on Automatic v0.8.0!

This version brings a couple of new features:

1. URL rewriting: Apparently sometimes the RSS feed contains slightly wrong torrent URLs, that point to nowhere, or the downloaded torrent is invalid. With URL rewriting you can now fix that. Details on how to set this up are in the updated automatic.conf-sample.

2. Reload settings without restarting Automatic: Automatic will now reload its configuration file when it receives a SIGHUP signal.

3. Any string option that becomes very long can now be split over multiple lines in the configuration files. Just make sure you add a '\' or a '+' at the end of a line that will continue on the next line:

Code:

filter = { pattern => "This.is.a.very.long.regular.expression" \
                                 "that.continues.on.a.new.line"
}

4. Automatic now tells the servers that it accepts encoded responses. This fixes the issue mcab reported a couple of days ago, but also reduces the network traffic a bit (I assume most sites will send RSS pages and torrent data in compressed form, if asked).

5. Some bugfixes here and there.


The source code is already available at Github, and you can download the package for ffp-0.7-arm from the first post.
The other packages will follow shortly.

Offline

 

#691 2012-06-14 11:44:14

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Automatic v0.8.0 is now available for ffp-0.5 and ffp-0.7-oabi as well.
Check the first post for download links.



And as always, let me know if something's not working right.

Offline

 

#692 2012-06-15 14:01:13

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

Does the old version need to be uninstalled first?

Offline

 

#693 2012-06-15 14:03:17

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

No, funpkg supports upgrading a package as well:

Code:

$ funpkg
Usage: funpkg <command> [options] <packages..>
Commands:
 -t       List package archive contents
 -x       Extract package archive
 -i       Install package
 -I       Reinstall package
 -u       Upgrade package
 -r       Remove package
 -p       Purge package
 -q       List installed packages
Options:
 -f       Ignore rules
 -C ROOT  Set system root directory

Offline

 

#694 2012-06-18 06:42:26

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

log file is saying:
../src/state.c, 100: [load_state] Error: Unable to open statefile ' /i-data/md0/.transmission-daemon/automatic.state ' for reading: No such file or directory

have checked and state file is there but is 0bytes and last time accessed was 12th june

ive set it to automatically dload in config, but i'm getting this in log:

"metainfo": "PCFET0NUWVBFIGh0bWwgUFVCTElDICItLy9XM0MvL0RURCBYSFRNTCAxLjAgVHJhbnNpdGlvbmFsLy9FTiIgImh0dHA6Ly93d3cudzMub3JnL1RSL3hodG1sMS9EVEQveGh0bWwxLXRyYW5za
"download-dir": "/mnt/HD_a2/video/Films","paused": 0

Offline

 

#695 2012-06-18 13:42:16

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

Check that the state file has proper user rights. If you don't run Automatic as user 'root', that user has to have access rights for the specified folder and read/write rights for the file.

Offline

 

#696 2012-06-18 23:14:20

m3cab
Member
Registered: 2012-06-11
Posts: 9

Re: [REL] Automatic for funplug-0.5

I think my problem is when I was installing transmission, I had to install it a few times and didn't delete the transmission files on the hdd. So I have about 3 transmission folders and automatic must be looking in the wrong place for transmission?

Offline

 

#697 2012-06-18 23:36:03

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

You can use Any path for the state file, just edit your automatic.conf.
The file does not need to be saved to the transmission settings folder, that was just convenience.
Remember to restart Automatic after you make changes to the configuration.

Offline

 

#698 2012-07-15 11:55:17

sventunus
New member
Registered: 2012-07-15
Posts: 1

Re: [REL] Automatic for funplug-0.5

Hy Kyle,

I just tried compiling Automatic 0.8.0 on my ReadyNAS Ultra 6, but I'm running into some problems.
I found this thread mentioned in the configure.log by the way, so that's how I'm here asking for your help.

Autogen.sh finished without problems, but running ./configure fails with the following errors:

checking for strip... strip
./configure: line 4010: syntax error near unexpected token `LIBCURL,'
./configure: line 4010: `PKG_CHECK_MODULES(LIBCURL, libcurl >= $CURL_MINIMUM)'

I have all the necessary dependencies installed:

megapinnemuts:~# dpkg -l libcurl*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                                                  Version                                               Description
+++-=====================================================-=====================================================-==========================================================================================================================
un  libcurl2                                              <none>                                                (no description available)
ii  libcurl3                                              7.19.7-1.netgear1                                     Multi-protocol file transfer library (OpenSSL)
un  libcurl4                                              <none>                                                (no description available)
ii  libxml2                                               2.6.32.dfsg-5+lenny4                                  GNOME XML library
un  libpcre1-dev                                          <none>                                                (no description available)
un  libpcre2-dev                                          <none>                                                (no description available)
ii  libpcre3                                              7.6-2.1                                               Perl 5 Compatible Regular Expression Library - runtime files
ii  libpcre3-dev                                          7.6-2.1                                               Perl 5 Compatible Regular Expression Library - development files
ii  libpcrecpp0                                           7.6-2.1                                               Perl 5 Compatible Regular Expression Library - C++ runtime files
ii  autotools-dev                                         20060702.1                                            Update infrastructure for config.{guess,sub}

The minimum versions for these libraries don't seem to be the problem either. In configure I find:

CURL_MINIMUM=7.15.0
LIBXML2_MINIMUM=2.6.31
PCRE_MINIMUM=7.4

And I have the following configuration for cURL:

megapinnemuts:~# curl -V
curl 7.19.2 (sparc-unknown-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8o
Protocols: tftp ftp telnet dict http file https ftps
Features: Largefile NTLM SSL

Could you point me to a solution?
Thanks in advance!

Sven

Offline

 

#699 2012-07-16 10:19:31

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Automatic for funplug-0.5

With the information you provided I would assume that
A) you haven't installed pkg-config, which is used to find package dependencies and such,
or
B) your autotools don't know about pkg-config for some reason. On my installation, there's a file /ffp/share/aclocal/pkg.m4 (for you it's probably /opt/share/aclocal or /usr/share/aclocal) that defines the auto-macro PKG_CHECK_MODULES, which apparently is not resolved on your machine.

I'm surprised autogen.sh didn't show any warnings/errors.

Offline

 

#700 2012-08-24 00:18:10

Komano
Member
Registered: 2011-06-10
Posts: 42

Re: [REL] Automatic for funplug-0.5

Hello KyleK,

Sorry to bother but i'm getting an error a guy got on Page 14 on this thread. Didn't see a fix posted for it and you asked for his automatic.conf privately. Do you need mine too?

This is the specific error i'm getting  Error uploading torrent: no method name <-

Only specific feeds are broken, the rest are fine. Interesting though.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB